$re = '/^(?=(?:.+?\.){2,}.*$)[a-z]{1,2}(?:\.[a-z]{1,2})+$/m';
$str = 'a.b.c.d
a.b
a.b.c
a.bb.c
aaa.bb.c
ab.c.dd.ee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);