re = /^(?=(?:.+?\.){2,}.*$)[a-z]{1,2}(?:\.[a-z]{1,2})+$/m
str = 'a.b.c.d
a.b
a.b.c
a.bb.c
aaa.bb.c
ab.c.dd.ee'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end