const regex = /^Disallow: \/(\s+)?$/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^Disallow: \\\/(\\s+)?$', 'm')
const str = `User-agent: *
Disallow: /
Disallow: /c/portal/.
Disallow: /wp-admin/
Disallow: /*/wp-admin/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}