re = /^Disallow: \/(\s+)?$/m
str = 'User-agent: *
Disallow: /
Disallow: /c/portal/.
Disallow: /wp-admin/
Disallow: /*/wp-admin/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end