$re = '/^Disallow: \/(\s+)?$/m';
$str = 'User-agent: *
Disallow: /
Disallow: /c/portal/.
Disallow: /wp-admin/
Disallow: /*/wp-admin/';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);