$re = '/^\[(?:\d+(?:,\d+)*)?\]$/m';
$str = '[1]
[1,2]
Nope
[]
[try]
[\'again\']
[1,2,3]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);