import re
regex = re.compile(r"^\[(?:\d+(?:,\d+)*)?\]$", flags=re.MULTILINE)
test_str = ("[1]\n"
"[1,2]\n"
"Nope\n"
"[]\n"
"[try]\n"
"['again']\n"
"[1,2,3]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")