re = /^\[(?:\d+(?:,\d+)*)?\]$/m
str = '[1]
[1,2]
Nope
[]
[try]
[\'again\']
[1,2,3]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end