using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[ ]\d{1,2}[ ][A-Z]{3}[ ]";
string input = @" 11 ASD
1 BKN 15 BKN
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}