const regex = new RegExp('^[ ]\\d{1,2}[ ][A-Z]{3}[ ]', '')
const str = ` 11 ASD
1 BKN 15 BKN
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}