#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\b\w*(\w) +(?=\1))+\w+"
Local $sString = "worD Dark king glow" & @CRLF & _
"word dark king glow we end" & @CRLF & _
"word dark king glow we end hello bye low wing" & @CRLF & _
"" & @CRLF & _
"AB ba a" & @CRLF & _
"A A" & @CRLF & _
"A B" & @CRLF & _
"AB B" & @CRLF & _
"AB BC D" & @CRLF & _
"AB BC CE" & @CRLF & _
"AB C" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")