re = /(?:\b\w*(\w) +(?=\1))+\w+/mi
str = 'worD Dark king glow
word dark king glow we end
word dark king glow we end hello bye low wing
AB ba a
A A
A B
AB B
AB BC D
AB BC CE
AB C
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end