use strict;
my $str = 'worD Dark king glow
word dark king glow we end
word dark king glow we end hello bye low wing
AB ba a
A A
A B
AB B
AB BC D
AB BC CE
AB C
';
my $regex = qr/(?:\b\w*(\w) +(?=\1))+\w+/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}