import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[Hh]eading\\t(\\d+)\\t[\\d\\.]+\\t(.+)";
final String string = "heading 1 0. References\n"
+ "heading 1 1. Introduction\n"
+ "heading 1 2. System of interest: heavy component\n"
+ "heading 2 2.1 Definition and role of the heavy component\n"
+ "heading 3 2.1.1 General Definitions\n"
+ "heading 3 2.1.2 heavy component main missions\n"
+ "heading 11 2.1.1.11.3.4 Generic chapter\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}