re = /^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)/m
str = 'heading 1 0. References
heading 1 1. Introduction
heading 1 2. System of interest: heavy component
heading 2 2.1 Definition and role of the heavy component
heading 3 2.1.1 General Definitions
heading 3 2.1.2 heavy component main missions
heading 11 2.1.1.11.3.4 Generic chapter
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end