using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"index_[1-4]?\d\.html";
string input = @"index_4.html
index_50.html
index_15.html
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}