$re = '/index_[1-4]?\d\.html/m';
$str = 'index_4.html
index_50.html
index_15.html
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);