package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)index_[1-4]?\d\.html`)
var str = `index_4.html
index_50.html
index_15.html
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}