#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=.)[^@\n](?=[^@\n]*?[^@\n]@)|(?:(?<=@.)|(?!^)\G(?=[^@\n]*$)).(?=.*[^@\n]\.)"
Local $sString = "john.doe@example.en.com" & @CRLF & _
"foo@bar.com" & @CRLF & _
"foo-and.more!here@bar.com" & @CRLF & _
"fo@bar.com" & @CRLF & _
"f@bar.com"
Local $sSubst = "*"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)