use strict;
my $str = 'john.doe@example.en.com
foo@bar.com
foo-and.more!here@bar.com
fo@bar.com
f@bar.com';
my $regex = qr/(?<=.)[^@\n](?=[^@\n]*?[^@\n]@)|(?:(?<=@.)|(?!^)\G(?=[^@\n]*$)).(?=.*[^@\n]\.)/mp;
my $subst = '*';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";