package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?<key>[^:]+):(?<value>[^,]+)`)
var str = `tag.Name:test,age:30,name:TestName123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}