$re = '/(?<key>[^:]+):(?<value>[^,]+)/';
$str = 'tag.Name:test,age:30,name:TestName123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);