re = /(?<key>[^:]+):(?<value>[^,]+)/
str = 'tag.Name:test,age:30,name:TestName123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end