using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[pid [0-9]+\]";
string input = @"Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client ""192.168.50.30""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}