// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[pid [0-9]+\]").unwrap();
let string = "Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client \"192.168.50.30\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}