re = /\[pid [0-9]+\]/m
str = 'Fri Apr 26 06:41:59 2019 [pid 5805] [user2] OK LOGIN: Client "192.168.50.30"
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end