#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[A-Z]+_[A-Z]*[0-9]+\b"
Local $sString = "INBZTEC_VTM855" & @CRLF & _
"INBZTEC_HBNE454" & @CRLF & _
"INABTEC_AVCM128" & @CRLF & _
"HOBZTEC_GVM4122" & @CRLF & _
"DOAZTEC_ZBM1244" & @CRLF & _
"BTCACS_898" & @CRLF & _
"BOCCIS_123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")