package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[A-Z]+_[A-Z]*[0-9]+\b`)
var str = `INBZTEC_VTM855
INBZTEC_HBNE454
INABTEC_AVCM128
HOBZTEC_GVM4122
DOAZTEC_ZBM1244
BTCACS_898
BOCCIS_123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}