$re = '/\b[A-Z]+_[A-Z]*[0-9]+\b/m';
$str = 'INBZTEC_VTM855
INBZTEC_HBNE454
INABTEC_AVCM128
HOBZTEC_GVM4122
DOAZTEC_ZBM1244
BTCACS_898
BOCCIS_123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);