using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"uWR.+Accept\s+\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},rc=\d{2}";
string input = @"03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00
03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}