package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`uWR.+Accept\s+\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},\d{2},rc=\d{2}`)
var str = `03712 13:29:16:328 uWR 724 Accept 00,01,02,00,00,00,00,00,00,32,32,rc=00
03712 13:29:17:515 uRD 724 Accept 00,01,00,rc=00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}