import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([A-Z])\\1{0,2}(?:100|[1-9]\\d|\\d)\\b";
final String string = "A1\n"
+ "AA2\n"
+ "AAA3\n"
+ "B5\n"
+ "CC7\n"
+ "AAAA12\n"
+ "AA99\n"
+ "XY12\n"
+ "XXX100";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}