const regex = /\b([A-Z])\1{0,2}(?:100|[1-9]\d|\d)\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b([A-Z])\\1{0,2}(?:100|[1-9]\\d|\\d)\\b', 'gm')
const str = `A1
AA2
AAA3
B5
CC7
AAAA12
AA99
XY12
XXX100`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}