$re = '/\b([A-Z])\1{0,2}(?:100|[1-9]\d|\d)\b/m';
$str = 'A1
AA2
AAA3
B5
CC7
AAAA12
AA99
XY12
XXX100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);