const regex = /(?=^.{1,10}$)^([A-Z]{1,4}\s*[0-9]{1,6})$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.{1,10}$)^([A-Z]{1,4}\\s*[0-9]{1,6})$', '')
const str = `ART155342`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}