$re = '/(?=^.{1,10}$)^([A-Z]{1,4}\s*[0-9]{1,6})$/';
$str = 'ART155342';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);