import Foundation
let pattern = #"(?=^.{1,10}$)^([A-Z]{1,4}\s*[0-9]{1,6})$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"ART155342"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}