#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?![0.]+$)(?:\d{1,2}(?:\.\d{1,10})?|100(?:\.0{1,10})?)$"
Local $sString = "0.000" & @CRLF & _
"0" & @CRLF & _
"0.01" & @CRLF & _
"1" & @CRLF & _
"5.1234567890" & @CRLF & _
"9.77777777777" & @CRLF & _
"10" & @CRLF & _
"21" & @CRLF & _
"33" & @CRLF & _
"65" & @CRLF & _
"89.7766" & @CRLF & _
"99.55654" & @CRLF & _
"99.0000" & @CRLF & _
"100" & @CRLF & _
"100." & @CRLF & _
"100.0" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")