re = /^(?![0.]+$)(?:\d{1,2}(?:\.\d{1,10})?|100(?:\.0{1,10})?)$/m
str = '0.000
0
0.01
1
5.1234567890
9.77777777777
10
21
33
65
89.7766
99.55654
99.0000
100
100.
100.0
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end