import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?![0.]+$)(?:\\d{1,2}(?:\\.\\d{1,10})?|100(?:\\.0{1,10})?)$";
final String string = "0.000\n"
+ "0\n"
+ "0.01\n"
+ "1\n"
+ "5.1234567890\n"
+ "9.77777777777\n"
+ "10\n"
+ "21\n"
+ "33\n"
+ "65\n"
+ "89.7766\n"
+ "99.55654\n"
+ "99.0000\n"
+ "100\n"
+ "100.\n"
+ "100.0\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}