using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\s*excelent(\w)?(?<!,)(\s)calidad(.){1,3}(\S)?)";
string input = @"Expresión regular para capturar ""Calidad Excelente"" o ""Excelente Calidad""
Lo mismo se hará con el resto de calificativos:
tiene una calidad excelente,
calidad excelente
calidades excelentísimas
EXCELENTE CALIDAD
calidad excelentísima rwtytrurturutufrei u
calidad realmente excelente,
calidades excelentísimas
Regulares calidades, excelentes vistas ---la coma actúa como separador mediante (?<!,)
Regulares calidades. excelentes vistas ---el punto no como separador mediante (?<!.)
excelente calidad -orden contrario
excelentísimas calidades -orden contrario
excelentes y buenas calidades -orden contrario
una calidad rmente excelente que tiene de todo---lo hacemos con .{1,7}
Pendiente:
Excelente calidad --- no lo captura por la E mayúscula";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}