import Foundation
let pattern = #"(\s*excelent(\w)?(?<!,)(\s)calidad(.){1,3}(\S)?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Expresión regular para capturar "Calidad Excelente" o "Excelente Calidad"
Lo mismo se hará con el resto de calificativos:
tiene una calidad excelente,
calidad excelente
calidades excelentísimas
EXCELENTE CALIDAD
calidad excelentísima rwtytrurturutufrei u
calidad realmente excelente,
calidades excelentísimas
Regulares calidades, excelentes vistas ---la coma actúa como separador mediante (?<!,)
Regulares calidades. excelentes vistas ---el punto no como separador mediante (?<!.)
excelente calidad -orden contrario
excelentísimas calidades -orden contrario
excelentes y buenas calidades -orden contrario
una calidad rmente excelente que tiene de todo---lo hacemos con .{1,7}
Pendiente:
Excelente calidad --- no lo captura por la E mayúscula
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)