# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\s*excelent(\w)?(?<!,)(\s)calidad(.){1,3}(\S)?)"
test_str = ("Expresión regular para capturar \"Calidad Excelente\" o \"Excelente Calidad\"\n"
"Lo mismo se hará con el resto de calificativos:\n\n"
"tiene una calidad excelente, \n"
" calidad excelente \n"
" calidades excelentísimas\n"
" EXCELENTE CALIDAD\n"
" calidad excelentísima rwtytrurturutufrei u\n"
" calidad realmente excelente,\n"
"calidades excelentísimas\n"
"Regulares calidades, excelentes vistas ---la coma actúa como separador mediante (?<!,)\n"
"Regulares calidades. excelentes vistas ---el punto no como separador mediante (?<!.)\n"
"excelente calidad -orden contrario\n"
" excelentísimas calidades -orden contrario\n"
"excelentes y buenas calidades -orden contrario\n"
"una calidad rmente excelente que tiene de todo---lo hacemos con .{1,7}\n\n"
"Pendiente:\n"
" Excelente calidad --- no lo captura por la E mayúscula")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.