#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m) |\t+"
Local $sString = "1.6 # blah blah blah" & @CRLF & _
"# fjsadfklj slkjf yes 3.4" & @CRLF & _
"1.8*" & @CRLF & _
"1.9 1.10 #blah" & @CRLF & _
"#blah" & @CRLF & _
"1.11"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)