using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" |\t+";
string substitution = @"";
string input = @"1.6 # blah blah blah
# fjsadfklj slkjf yes 3.4
1.8*
1.9 1.10 #blah
#blah
1.11";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}