import re
regex = re.compile(r" |\t+", flags=re.MULTILINE)
test_str = ("1.6 # blah blah blah\n"
"# fjsadfklj slkjf yes 3.4\n"
"1.8*\n"
"1.9 1.10 #blah\n"
"#blah\n"
"1.11")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)