package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\w+(?:'\w+)? ){0,2}WORDHERE(?: \w+(?:'\w+)?){0,2}`)
var str = `you're not WORDHERE is the best
the worst WORDHERE surely didn't win
not WORDHERE is the best`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}