$re = '/(?:\w+(?:\'\w+)? ){0,2}WORDHERE(?: \w+(?:\'\w+)?){0,2}/m';
$str = 'you\'re not WORDHERE is the best
the worst WORDHERE surely didn\'t win
not WORDHERE is the best';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);