$re = '/^(?!666|000|9[0-9]{2})[0-9]{3}[-]?(?!00)[0-9]{2}[-]?(?!0{4})[0-9]{4}$/m';
$str = '123-45-6789
123456789
001341343
888-03-1785
888-04-0001
666-23-1234
666231234
000-65-1343
000651343
905-31-6375
905316375
888-00-1785
888001785
888-04-0000
888040000
666-00-0000
666-01-4050';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);