# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!666|000|9[0-9]{2})[0-9]{3}[-]?(?!00)[0-9]{2}[-]?(?!0{4})[0-9]{4}$"
test_str = ("123-45-6789\n"
"123456789\n"
"001341343\n"
"888-03-1785\n"
"888-04-0001\n\n\n"
"666-23-1234\n"
"666231234\n"
"000-65-1343\n"
"000651343\n"
"905-31-6375\n"
"905316375\n"
"888-00-1785\n"
"888001785\n"
"888-04-0000\n"
"888040000\n"
"666-00-0000\n"
"666-01-4050")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.